summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-09 23:02:17 +0100
committerAki <please@ignore.pl>2024-03-09 23:02:17 +0100
commite1606f9bbc45e7ba57c461dc1ca4d4a86c5d76dd (patch)
treed13c968b28d8f9a076b7fed0d6f098fc448ce87c /CMakeLists.txt
parenteced12a69603e23d6869f92a2d5302f4605354ba (diff)
downloadstarshatter-e1606f9bbc45e7ba57c461dc1ca4d4a86c5d76dd.zip
starshatter-e1606f9bbc45e7ba57c461dc1ca4d4a86c5d76dd.tar.gz
starshatter-e1606f9bbc45e7ba57c461dc1ca4d4a86c5d76dd.tar.bz2
Replaced MachineInfo with stripped cross-platform solution
It could easily handle more, but is there really need for it? Having some information about the machine in logs is nice, but with the current state of affairs most of errors are coming from bad pointer uses than anything else... InfoEx is STATIC, because it seems FoundationEx can cause multiple definitions in scenarios like this.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b29d20..4b3575c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ add_subdirectory(contrib)
add_subdirectory(data)
add_subdirectory(DefinitionEx)
add_subdirectory(FoundationEx)
+add_subdirectory(InfoEx)
if(MSVC)
add_subdirectory(Magic2)
endif()