summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-08-07 21:45:05 +0200
committerAki <please@ignore.pl>2022-08-07 21:49:13 +0200
commit9ae3b193c461b168336d1d9e272aa834705633d7 (patch)
treecf4dde4eeba653763ab3180e4d581f359899370d /CMakeLists.txt
parent59af3b9729cb325fa65698f534bb87e77401c6a6 (diff)
downloadstarshatter-9ae3b193c461b168336d1d9e272aa834705633d7.zip
starshatter-9ae3b193c461b168336d1d9e272aa834705633d7.tar.gz
starshatter-9ae3b193c461b168336d1d9e272aa834705633d7.tar.bz2
Reimplemented part of archive format
This is getting reimplemented rather than refactor mostly in order to make clear which parts are needed for backwards compatiblity (reading-wise) and which are not. The current implementation has quite a number of quirks and potential failure points despite not being large. Understanding them is not worth it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdb33d6..fea3356 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ if(MSVC)
set(WINDOWSSDK_LIBPATH "C:/Program Files (x86)/Windows Kits/10/Lib/10.0.19041.0" CACHE FILEPATH "Path to a versioned lib directory of selected Windows SDK")
set(WINDOWSSDK_PATH "C:/Program Files (x86)/Windows Kits/10/Include/10.0.19041.0" CACHE FILEPATH "Path to a versioned include directory of selected Windows SDK")
endif()
+add_subdirectory(ArchiveEx)
add_subdirectory(contrib)
add_subdirectory(data)
add_subdirectory(Datafile)