summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-07 23:59:51 +0100
committerAki <please@ignore.pl>2024-03-07 23:59:51 +0100
commit3f857bb284d3c8aa99bcd61980e0f0cab2dd8e19 (patch)
tree4a2724f89ce213b1834d5550229243cccfad9fb3 /CMakeLists.txt
parent1ef05b8b227194ec32ae49f0eaf3e483ef35bb6b (diff)
downloadstarshatter-3f857bb284d3c8aa99bcd61980e0f0cab2dd8e19.zip
starshatter-3f857bb284d3c8aa99bcd61980e0f0cab2dd8e19.tar.gz
starshatter-3f857bb284d3c8aa99bcd61980e0f0cab2dd8e19.tar.bz2
Added gtest to the project and a stub test for showcase
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e878572..8b29d20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,10 @@ set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_EXTENSIONS Yes)
set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
project(Starshatter)
+enable_testing()
include(AddVersionFile)
+include(GenerateEmulator)
+include(GoogleTest)
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
if(CMAKE_HOST_SYSTEM_NAME MATCHES Windows)
set(CMAKE_INSTALL_PREFIX "C:/Program Files (x86)/Starshatter" CACHE PATH "Prefix to install to" FORCE)