summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-04-01 21:42:56 +0200
committerAki <please@ignore.pl>2022-04-01 22:21:44 +0200
commit3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2 (patch)
tree234fe74a29b15e37b8dbd40d1d58da9286c6b851 /CMakeLists.txt
parent3c487c5cd69c53d6fea948643c0a76df03516605 (diff)
downloadstarshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.zip
starshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.tar.gz
starshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.tar.bz2
Separated Main to own module
Intent is to separate headless server and game and make a dedicated executable for each. While this can be done without any directory changes, this is intended to cause as many compilation and linking errors as possible in order to clean them up and refactor general structure of the whole project.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 008dbe0..d527cac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,4 +21,5 @@ add_subdirectory(FoundationEx)
# add_subdirectory(Magic2) # TODO: AFX/MFC will be useless, port it to e.g., Qt right away.
add_subdirectory(NetEx)
add_subdirectory(StarsEx)
+add_subdirectory(Starshatter)
install(FILES NOTICE COPYING DESTINATION ${CMAKE_INSTALL_PREFIX})