summaryrefslogtreecommitdiffhomepage
path: root/ArchiveEx/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-08-07 21:45:05 +0200
committerAki <please@ignore.pl>2022-08-07 21:49:13 +0200
commit9ae3b193c461b168336d1d9e272aa834705633d7 (patch)
treecf4dde4eeba653763ab3180e4d581f359899370d /ArchiveEx/CMakeLists.txt
parent59af3b9729cb325fa65698f534bb87e77401c6a6 (diff)
downloadstarshatter-9ae3b193c461b168336d1d9e272aa834705633d7.zip
starshatter-9ae3b193c461b168336d1d9e272aa834705633d7.tar.gz
starshatter-9ae3b193c461b168336d1d9e272aa834705633d7.tar.bz2
Reimplemented part of archive format
This is getting reimplemented rather than refactor mostly in order to make clear which parts are needed for backwards compatiblity (reading-wise) and which are not. The current implementation has quite a number of quirks and potential failure points despite not being large. Understanding them is not worth it.
Diffstat (limited to 'ArchiveEx/CMakeLists.txt')
-rw-r--r--ArchiveEx/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/ArchiveEx/CMakeLists.txt b/ArchiveEx/CMakeLists.txt
new file mode 100644
index 0000000..b2a1948
--- /dev/null
+++ b/ArchiveEx/CMakeLists.txt
@@ -0,0 +1,13 @@
+project(ArchiveEx)
+add_library(
+ ArchiveEx
+ Archive.cpp
+ )
+target_include_directories(
+ ArchiveEx
+ PUBLIC .
+ )
+target_link_libraries(
+ ArchiveEx
+ PRIVATE Zlib::zlib
+ )