summaryrefslogtreecommitdiff
path: root/daemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/CMakeLists.txt')
-rw-r--r--daemon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
new file mode 100644
index 0000000..831dae3
--- /dev/null
+++ b/daemon/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(daemon CXX)
+add_executable(${PROJECT_NAME}
+ src/daemon.cpp
+ )
+target_link_libraries(${PROJECT_NAME}
+ PRIVATE rpclib::rpc
+ PRIVATE Threads::Threads
+ PRIVATE common
+ )
+install(TARGETS ${PROJECT_NAME}
+ RUNTIME
+ )