summaryrefslogtreecommitdiff
path: root/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-14 22:51:43 +0200
committerAki <please@ignore.pl>2021-10-14 22:51:43 +0200
commit0dd0ba272f247ca6e9b7948b648e42ff544c71ac (patch)
tree81d291a87456a6909d311f4b31ce6f56c5490dac /daemon/CMakeLists.txt
downloadhwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.zip
hwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.tar.gz
hwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.tar.bz2
Created stub daemon with a communication library
Diffstat (limited to 'daemon/CMakeLists.txt')
-rw-r--r--daemon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
new file mode 100644
index 0000000..831dae3
--- /dev/null
+++ b/daemon/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(daemon CXX)
+add_executable(${PROJECT_NAME}
+ src/daemon.cpp
+ )
+target_link_libraries(${PROJECT_NAME}
+ PRIVATE rpclib::rpc
+ PRIVATE Threads::Threads
+ PRIVATE common
+ )
+install(TARGETS ${PROJECT_NAME}
+ RUNTIME
+ )