summaryrefslogtreecommitdiff
path: root/library/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-06-16 21:43:35 +0200
committerAki <please@ignore.pl>2022-06-16 21:43:35 +0200
commit4269e0c8b0cb3b10eedef9895303032d0ff798f5 (patch)
tree36a50c48ea069553d1b6f8c06bf38f89f2cb9e3d /library/CMakeLists.txt
parent2a613260c0a9157f26155442bc0dd8a26b634b06 (diff)
downloadhwd-4269e0c8b0cb3b10eedef9895303032d0ff798f5.zip
hwd-4269e0c8b0cb3b10eedef9895303032d0ff798f5.tar.gz
hwd-4269e0c8b0cb3b10eedef9895303032d0ff798f5.tar.bz2
Added pkgconfig module file
Diffstat (limited to 'library/CMakeLists.txt')
-rw-r--r--library/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/library/CMakeLists.txt b/library/CMakeLists.txt
index 71ed16c..f3f905b 100644
--- a/library/CMakeLists.txt
+++ b/library/CMakeLists.txt
@@ -22,6 +22,10 @@ configure_package_config_file(
${CMAKE_CURRENT_BINARY_DIR}/HwdConfig.cmake
INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/Hwd
)
+configure_file(hwd.pc.in hwd.pc @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/hwd.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ )
install(TARGETS ${PROJECT_NAME}
EXPORT HwdTargets
RUNTIME