summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-05-20 19:56:43 +0200
committerAki <please@ignore.pl>2022-05-20 19:58:21 +0200
commit650d81b8d185ae54e456b5159c3b94e0df94e252 (patch)
treeb392cd12fc4cd3ce33ff9bc5bf27c24c0e675ba0 /CMakeLists.txt
parentd3720f01837e949ce7e7ea9b119358a5bb7b9666 (diff)
downloadderelict-650d81b8d185ae54e456b5159c3b94e0df94e252.zip
derelict-650d81b8d185ae54e456b5159c3b94e0df94e252.tar.gz
derelict-650d81b8d185ae54e456b5159c3b94e0df94e252.tar.bz2
Enabled warnings during compilation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30ff0fe..e300660 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,3 +17,7 @@ target_link_libraries(
raylib
nlohmann_json::nlohmann_json
)
+target_compile_options(
+ ${PROJECT_NAME}
+ PRIVATE -Wall -Wextra -Wpedantic
+)