summaryrefslogtreecommitdiffhomepage
path: root/nGenEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'nGenEx/CMakeLists.txt')
-rw-r--r--nGenEx/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/nGenEx/CMakeLists.txt b/nGenEx/CMakeLists.txt
index fe54396..a73d239 100644
--- a/nGenEx/CMakeLists.txt
+++ b/nGenEx/CMakeLists.txt
@@ -80,6 +80,11 @@ target_include_directories(
nGenEx
PUBLIC .
PUBLIC $ENV{DXSDK_DIR}/Include
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../Opcode/OpcodeLib # FIXME: Opcode is badly injured.
+ )
+target_precompile_headers(
+ nGenEx
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../Opcode/OpcodeLib/StdAfx.h
)
target_link_libraries(
nGenEx
@@ -90,5 +95,5 @@ target_link_libraries(
PUBLIC Vorbis::vorbisfile
PUBLIC Ogg::ogg
PUBLIC Png::png
- # TODO: PUBLIC Opcode::opcode
+ PUBLIC Opcode
)