summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..eebfff4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 3.19)
+project(mingw-cmake-toolchains NONE)
+set(MINGW_TOOLCHAINS i686-w64-mingw32 x86_64-w64-mingw32)
+include(GNUInstallDirs)
+foreach(MINGW_TOOLCHAIN IN ITEMS ${MINGW_TOOLCHAINS})
+ configure_file(toolchain.cmake.in "${MINGW_TOOLCHAIN}.cmake" @ONLY)
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/${MINGW_TOOLCHAIN}.cmake"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/toolchains")
+endforeach()