summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e07cd2c..fee45df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,16 +8,13 @@ set(STEAM_APPID $ENV{STEAM_APPID} CACHE STRING "App ID for steam deployment")
set(STEAM_DEPOTID_WINDOWS $ENV{STEAM_DEPOTID_WINDOWS} CACHE STRING "Steam Depot ID for Windows builds")
set(STEAM_DEPOTID_LINUX $ENV{STEAM_DEPOTID_LINUX} CACHE STRING "Steam Depot ID for Linux builds")
set(CMAKE_INSTALL_BINDIR .)
-set(raylib_USE_STATIC_LIBS Yes)
enable_testing()
-find_package(EnTT 3 REQUIRED)
-find_package(GTest 1 REQUIRED)
-find_package(nlohmann_json 3 REQUIRED)
-find_package(raylib 4 REQUIRED)
include(AddResources)
include(AddVersionFile)
+include(FetchContent)
+include(GoogleTest)
+add_subdirectory(contrib) # Out of order to handle dependencies.
add_subdirectory(campaign)
-add_subdirectory(contrib)
add_subdirectory(engine)
add_subdirectory(kurator)
add_subdirectory(sim)