summaryrefslogtreecommitdiff
path: root/sim/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-12-03 00:44:07 +0100
committerAki <please@ignore.pl>2022-12-03 00:44:07 +0100
commit18a763bcb19c5ece4b7b7d079dab07a1d915deb6 (patch)
tree137278522c98f5cb5cf4067886444b20b3eaf82d /sim/CMakeLists.txt
parent18eba7f30381c05ee1c03bec5f537ec7d4dc9815 (diff)
downloadkurator-18a763bcb19c5ece4b7b7d079dab07a1d915deb6.zip
kurator-18a763bcb19c5ece4b7b7d079dab07a1d915deb6.tar.gz
kurator-18a763bcb19c5ece4b7b7d079dab07a1d915deb6.tar.bz2
Moved battles module files to sim
Diffstat (limited to 'sim/CMakeLists.txt')
-rw-r--r--sim/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/sim/CMakeLists.txt b/sim/CMakeLists.txt
new file mode 100644
index 0000000..f7478e3
--- /dev/null
+++ b/sim/CMakeLists.txt
@@ -0,0 +1,21 @@
+project(battles)
+add_library(
+ ${PROJECT_NAME}
+ src/BaseBattle.cpp
+ src/Battle.cpp
+ src/Builder.cpp
+ src/Point.cpp
+ src/RandomSpawner.cpp
+ src/Scenario.cpp
+ src/scenarios.cpp
+ src/TeamManager.cpp
+)
+target_include_directories(
+ ${PROJECT_NAME}
+ PUBLIC include
+)
+target_link_libraries(
+ ${PROJECT_NAME}
+ PUBLIC EnTT::EnTT
+ PUBLIC universe
+)