summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2023-01-26 17:28:42 +0100
committerAki <please@ignore.pl>2023-01-26 17:31:38 +0100
commita40e6361ba7172e0a3f3b16e2d286db9928e94e2 (patch)
tree6e9d32a8a3e87fcedfb963f77f5c97d365fab437 /CMakeLists.txt
parent0df01f74aac44831c7a8e181625058d2db6b8133 (diff)
downloadkurator-a40e6361ba7172e0a3f3b16e2d286db9928e94e2.zip
kurator-a40e6361ba7172e0a3f3b16e2d286db9928e94e2.tar.gz
kurator-a40e6361ba7172e0a3f3b16e2d286db9928e94e2.tar.bz2
Added build version identification to title screen
Since this uses configure_file it might have problems sometimes when trying to detect updated value. It will be better to move it to use custom target instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 145635f..fe35ab7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,9 +8,12 @@ find_package(EnTT 3 REQUIRED)
find_package(nlohmann_json 3 REQUIRED)
find_package(raylib 4 REQUIRED)
include(AddResources)
+include(GitRevParse)
+git_rev_parse(KURATOR_VERSION)
add_subdirectory(campaign)
add_subdirectory(contrib)
add_subdirectory(kurator)
add_subdirectory(sim)
add_subdirectory(stats)
add_subdirectory(universe)
+configure_file(version.txt.conf "${CMAKE_CURRENT_BINARY_DIR}/version.txt" @ONLY)