summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2023-02-05 01:18:18 +0100
committerAki <please@ignore.pl>2023-02-05 01:18:18 +0100
commit7c8aac19374013e7366b5afbf5d85fe151de3669 (patch)
treea447bf2c9366eb222ca37e29f679c84a166a4d18 /CMakeLists.txt
parentdedd9566a53de73215a13117e2704e8df4d04e95 (diff)
downloadkurator-7c8aac19374013e7366b5afbf5d85fe151de3669.zip
kurator-7c8aac19374013e7366b5afbf5d85fe151de3669.tar.gz
kurator-7c8aac19374013e7366b5afbf5d85fe151de3669.tar.bz2
Added simple test for HitPoints
This should have been added earlier. The test itself is questionable and overall very optimistic about the edge cases. The intent of this commit is purely set up of the testing framework.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae2a9b8..da56f8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,10 +1,12 @@
-cmake_minimum_required(VERSION 3.16)
+cmake_minimum_required(VERSION 3.20)
project(kurator)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_EXTENSIONS No)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wpedantic -D_USE_MATH_DEFINES")
set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
+enable_testing()
find_package(EnTT 3 REQUIRED)
+find_package(GTest 1 REQUIRED)
find_package(nlohmann_json 3 REQUIRED)
find_package(raylib 4 REQUIRED)
include(AddResources)