summaryrefslogtreecommitdiff
path: root/examples/sinewave/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sinewave/CMakeLists.txt')
-rw-r--r--examples/sinewave/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/sinewave/CMakeLists.txt b/examples/sinewave/CMakeLists.txt
index 9c851c9..6f0c01f 100644
--- a/examples/sinewave/CMakeLists.txt
+++ b/examples/sinewave/CMakeLists.txt
@@ -1,9 +1,9 @@
cmake_minimum_required(VERSION 3.10)
project(sinewave CXX)
add_executable(sinewave sinewave.cpp)
-find_package(Hwd QUIET)
-if(Hwd_FOUND)
- target_link_libraries(sinewave Hwd::library)
+if(TARGET library)
+ add_library(Hwd::library ALIAS library)
else()
- target_link_libraries(sinewave library)
+ find_package(Hwd REQUIRED)
endif()
+target_link_libraries(sinewave Hwd::library)