summaryrefslogtreecommitdiff
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index 5c4c9e1..a126620 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -1,6 +1,7 @@
project(common CXX)
-add_library(${PROJECT_NAME} INTERFACE
+add_library(${PROJECT_NAME} STATIC
+ src/internal.cpp
)
target_include_directories(${PROJECT_NAME}
- INTERFACE include
+ PUBLIC include
)