summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-14 22:51:43 +0200
committerAki <please@ignore.pl>2021-10-14 22:51:43 +0200
commit0dd0ba272f247ca6e9b7948b648e42ff544c71ac (patch)
tree81d291a87456a6909d311f4b31ce6f56c5490dac /CMakeLists.txt
downloadhwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.zip
hwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.tar.gz
hwd-0dd0ba272f247ca6e9b7948b648e42ff544c71ac.tar.bz2
Created stub daemon with a communication library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f28fa63
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.18)
+project(hwd)
+include(GNUInstallDirs)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_EXTENSIONS No)
+find_package(Threads REQUIRED)
+find_package(rpclib 2 REQUIRED)
+add_subdirectory(common)
+add_subdirectory(daemon)
+add_subdirectory(library)
+add_subdirectory(sample_client)