summaryrefslogtreecommitdiff
path: root/sent/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'sent/PKGBUILD')
-rw-r--r--sent/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/sent/PKGBUILD b/sent/PKGBUILD
new file mode 100644
index 0000000..d1ec109
--- /dev/null
+++ b/sent/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aki <please at ignore pl>
+pkgname=sent
+pkgver=1
+pkgrel=1
+license=(ISC)
+pkgdesc='Simple plaintext presentation tool'
+arch=(x86_64 i686)
+depends=(libxft libx11 farbfeld)
+source=(
+ "https://dl.suckless.org/tools/${pkgname}-${pkgver}.tar.gz"
+ 'solarized.patch'
+ 'slide_numbers.patch'
+ 'font_scale.patch')
+sha256sums=(
+ '7bf3de9311ce291ff36adf5315b78fa72373e3ab80ca71387fb5884bcbd7be33'
+ '9e69d6b3690b5e96cac533ee75b1a5ff73e85840eb4b2557aaba53200f773690'
+ '7ce2f4a50fa5dbaa94c4301ae51c4e79ba3aad97f8ad93c166dbe30f0c86e9e9'
+ '1221885592ffb5df9817de2aac862e0de393d880326e67ad7b723863a4958907')
+
+
+prepare() {
+ patch --forward --strip=1 --input=solarized.patch
+ patch --forward --strip=1 --input=slide_numbers.patch
+ patch --forward --strip=1 --input=font_scale.patch
+}
+
+
+build() {
+ make
+}
+
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}