summaryrefslogtreecommitdiff
path: root/mingw-w64-cmake-toolchains/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mingw-w64-cmake-toolchains/PKGBUILD')
-rw-r--r--mingw-w64-cmake-toolchains/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/mingw-w64-cmake-toolchains/PKGBUILD b/mingw-w64-cmake-toolchains/PKGBUILD
new file mode 100644
index 0000000..eff5246
--- /dev/null
+++ b/mingw-w64-cmake-toolchains/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aki <please at ignore pl>
+
+pkgname=mingw-w64-cmake-toolchains
+pkgver=2426c84
+pkgrel=1
+arch=('any')
+pkgdesc="CMake toolchains for MinGW-w64"
+depends=('cmake' 'mingw-w64-gcc')
+optdepends=('wine: cross-compiling emulator for cmake')
+license=("None")
+url="https://git.ignore.pl/$pkgname/"
+source=("git+https://git.ignore.pl/$pkgname/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd $pkgname
+ cmake -B build --install-prefix="/usr"
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install "$pkgname/build"
+}