summaryrefslogtreecommitdiff
path: root/mingw-w64-cmake-toolchains-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mingw-w64-cmake-toolchains-git/PKGBUILD')
-rw-r--r--mingw-w64-cmake-toolchains-git/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/mingw-w64-cmake-toolchains-git/PKGBUILD b/mingw-w64-cmake-toolchains-git/PKGBUILD
new file mode 100644
index 0000000..67b70e4
--- /dev/null
+++ b/mingw-w64-cmake-toolchains-git/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Aki <please at ignore pl>
+
+_pkgname=mingw-w64-cmake-toolchains
+pkgname="$_pkgname-git"
+pkgver=2426c84
+pkgrel=1
+arch=('any')
+pkgdesc="CMake toolchains for MinGW-w64"
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+depends=('cmake' 'mingw-w64-gcc')
+optdepends=('wine: cross-compiling emulator for cmake')
+license=("None")
+url="https://git.ignore.pl/$_pkgname/"
+source=("git+https://git.ignore.pl/$_pkgname/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd $_pkgname
+ cmake -B build --install-prefix="/usr"
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install "$_pkgname/build"
+}