summaryrefslogtreecommitdiff
path: root/datever/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'datever/PKGBUILD')
-rw-r--r--datever/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/datever/PKGBUILD b/datever/PKGBUILD
new file mode 100644
index 0000000..d2c34f5
--- /dev/null
+++ b/datever/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Aki <please at ignore pl>
+
+pkgname=datever
+_commit=ea23c5d
+pkgver=20240618.3
+pkgrel=1
+license=(None)
+pkgdesc='Generate date-based version for git repository'
+arch=(any)
+depends=(libgit2)
+source=("${pkgname}::git+https://git.ignore.pl/${pkgname}#commit=${_commit}")
+sha256sums=('SKIP')
+
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make all
+}
+
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+}