summaryrefslogtreecommitdiff
path: root/mingw-w64-entt/PKGBUILD
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2023-01-21 16:05:19 +0100
committerAki <please@ignore.pl>2023-01-21 16:05:19 +0100
commit87ea240a28630d38dbea89f05eff0ff78da27025 (patch)
tree2089d1ae375d5ff3715b43c263cc626b337266a7 /mingw-w64-entt/PKGBUILD
parent845740548110db5605eb7536fdac8509939995d0 (diff)
downloadarch-ignore-87ea240a28630d38dbea89f05eff0ff78da27025.zip
arch-ignore-87ea240a28630d38dbea89f05eff0ff78da27025.tar.gz
arch-ignore-87ea240a28630d38dbea89f05eff0ff78da27025.tar.bz2
Added mingw-w64 version of entt package
Diffstat (limited to 'mingw-w64-entt/PKGBUILD')
-rw-r--r--mingw-w64-entt/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/mingw-w64-entt/PKGBUILD b/mingw-w64-entt/PKGBUILD
new file mode 100644
index 0000000..263e77d
--- /dev/null
+++ b/mingw-w64-entt/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=mingw-w64-entt
+pkgver=3.11.1
+pkgrel=1
+pkgdesc='A header-only, tiny and easy to use entity-component system (and much more) written in modern C++'
+url='https://skypjack.github.io/entt/'
+license=(MIT)
+arch=(any)
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/skypjack/entt/archive/v${pkgver}.tar.gz" 'cmake_install_libdir.patch')
+sha256sums=('0ac010f232d3089200c5e545bcbd6480cf68b705de6930d8ff7cdb0a29f5b47b' 'SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/entt-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/cmake_install_libdir.patch"
+}
+
+build() {
+ cd "${srcdir}/entt-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p "build-${_arch}" && pushd "${_}"
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Relase -DENTT_USE_LIBCPP=OFF _DENTT_BUULD_TESTING=OFF ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/entt-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ done
+}