summaryrefslogtreecommitdiff
path: root/wolfssh/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'wolfssh/PKGBUILD')
-rw-r--r--wolfssh/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/wolfssh/PKGBUILD b/wolfssh/PKGBUILD
deleted file mode 100644
index f63f379..0000000
--- a/wolfssh/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Aki <please@ignore.pl>
-pkgbase=wolfssh
-pkgname=(${pkgbase} ${pkgbase}-examples)
-pkgver=1.4.13
-pkgrel=5
-pkgdesc='Small, fast, portable SSH implementation, including support for SCP and SFTP'
-license=('GPL 2.0')
-arch=(x86_64 i686)
-makedepends=(autoconf)
-depends=(libtool wolfssl)
-source=("https://github.com/wolfSSL/${pkgbase}/archive/refs/tags/v${pkgver}-stable.tar.gz")
-sha256sums=('95de536d2390ca4a8a7f9be4b2faaaebb61dcedf2c6571107172d4a64347421c')
-
-
-build() {
- cd "${pkgbase}-${pkgver}-stable"
- ./autogen.sh
- ./configure --prefix=/usr --with-wolfssl=/usr --enable-certs --enable-scp --enable-sftp --enable-sshd \
- CPPFLAGS='-DWOLFSSH_NO_FPKI -DWOLFSSH_MAX_SFTP_RW=10485760' --enable-shared --disable-static
- make
-}
-
-
-package_wolfssh() {
- cd "${pkgbase}-${pkgver}-stable"
- make DESTDIR="${pkgdir}" install
-}
-
-package_wolfssh-examples() {
- depends=(libtool wolfssh)
- cd "${pkgbase}-${pkgver}-stable"
- mkdir -p "${pkgdir}/usr/bin"
- cp -r examples/client/{client,.libs} "${pkgdir}/usr/bin"
-}