summaryrefslogtreecommitdiffhomepage
path: root/StarsEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'StarsEx/CMakeLists.txt')
-rw-r--r--StarsEx/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/StarsEx/CMakeLists.txt b/StarsEx/CMakeLists.txt
index 1dc025d..1bacde7 100644
--- a/StarsEx/CMakeLists.txt
+++ b/StarsEx/CMakeLists.txt
@@ -329,3 +329,10 @@ else()
PUBLIC -l:libdxguid.a
)
endif()
+add_executable(
+ ${PROJECT_NAME}_test
+ test/AudioConfig.cpp
+ )
+generate_emulator(${PROJECT_NAME}_test LIBS Opcode ArchiveEx)
+target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
+gtest_discover_tests(${PROJECT_NAME}_test DISCOVERY_TIMEOUT 60)