summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8797278..0bca9e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,7 @@ set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_EXTENSIONS Yes)
set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
project(Starshatter)
+include(AddVersionFile)
include(GitDescribe)
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
if(CMAKE_HOST_SYSTEM_NAME MATCHES Windows)
@@ -28,7 +29,7 @@ add_subdirectory(NetEx)
add_subdirectory(Starserver)
add_subdirectory(StarsEx)
add_subdirectory(Starshatter)
-configure_file(version.txt.conf ${CMAKE_CURRENT_BINARY_DIR}/version.txt @ONLY)
+add_version_file(version.txt version.txt.conf)
install(
FILES NOTICE COPYING
COMPONENT Copyright